problem installing over ubuntu lucid 10.04

7 posts / 0 new
Last post
collazosc
collazosc's picture
Offline
Last seen: 1 month 3 weeks ago
Joined: Mar 16 2014
Junior Boarder

Posts: 4

carl colz
problem installing over ubuntu lucid 10.04

I'm trying to install infinidb binary edition over a linux VM with ubuntu server lucid 10.04. The server acts as a dedicated machine rented with a provider for serving web pages, it has its own IP, but only apache web server is running with a small mysql installation on port 3306  (I manage to install the same version on another ubuntu version 12.04 but running locally and I succeded even with mysql installed).

 

I changed the port to 3309 (as in my local installation) and run postConfigure (following the instructions in the installation manual), but after a lot of ........... (two rows and a lot of minutes) it says that installation has failed and to check var/log/calpont. Checking the logs there's nothing that suggest the error cause just an ui... file and some empty directories.

 

Looking the forum I found that some people had problems with the firewall. I disabled the firewall completely (and no apparmor installed in the machine) and tried again the installation but without lock.

 

I am lost and I do not know how to diagnose the problem since the logs don't show significant information. The machine has 6GB RAM and a lot of hard disk. I used root for performing the installation. Searched this forum and nothing.

 

What's wrong?

davidhill
davidhill's picture
Offline
Last seen: 1 month 5 days ago
Joined: Oct 27 2009
Administrator

Posts: 595

david hill
Hey Carl, lets get a bit more

Hey Carl, lets get a bit more information...

 

1. Are you installing as 'root' or a 'non-root' user?

2. In either case, did you run the ../Calpont/bin/post-install script before postConfigure?

    If non-root user, post-install will output some additional environment variables to run before postConfigure is run.

    So just double checking if those were run if you are installing as non-root.

 

David Hill  (InfiniDB)

collazosc
collazosc's picture
Offline
Last seen: 1 month 3 weeks ago
Joined: Mar 16 2014
Junior Boarder

Posts: 4

carl colz
David, thank you very much

David, thank you very much for you interest in helping.

 

About your questions:

 

I installed as root and yes I've run post-install. I tested .deb installer (then cleaned the machine) and tried the binary install with the hope that I could control better the logs and message errors. 

 

As I told you I installed succesfully in two machines using the .deb and bin installation. Both installations in Ubuntu 12.04 server edition. 

 

Regards,

davidhill
davidhill's picture
Offline
Last seen: 1 month 5 days ago
Joined: Oct 27 2009
Administrator

Posts: 595

david hill
Thanks for that additional

Thanks for that additional information.

 

First, lets see if the logs are setup.

1. Do you see in /var/log/Calpont directory a debug.log file plus a number of others?

    If yes, you have logs working, just nothing updating them.

    If no, run the following script to see if you get logs setup and check for logs afterwards

    # /usr/local/Calpont/bin/syslogSetup.sh install

 

2. Try starting up InfiniDB from the console, run the following commands to setup and run:

    # .  /usr/local/Calpont/bin/calpontAlias

    # cc     // to launch console

 

    InfiniDB > shutdownsystem y

    InfiniDB > startsystem

    InfiniDB > getsysteminfo

 

If the system fails to start, post the results of the commands above with anything in the err, warning, or crit logs (if we get any)

 

Now if the system does startup successfully, you will need to run teh following command. This would have been run at the end of postConfigure, if that had completed:

 

   # /usr/local/Calpont/bin/dbbuilder 7

 

David

collazosc
collazosc's picture
Offline
Last seen: 1 month 3 weeks ago
Joined: Mar 16 2014
Junior Boarder

Posts: 4

carl colz
David:

David:

 

1. Logs are setup so log is working.

 

2. Running the 3 comands all I get is (note that I intentionally changed the port to 3309 since I need to run mysql in 3306):

 

InfiniDB> shutdownsystem
shutdownsystem   Mon Apr 14 00:31:14 2014
ControllerSegmentTable: RWLock() threw: Function not implemented
terminate called after throwing an instance of 'boost::interprocess::interprocess_exception'
  what():  Function not implemented
Aborted
 
And CC is aborted.
 
3. Running 3 I got:
 
/usr/local/Calpont/mysql/db# /usr/local/Calpont/bin/dbbuilder 7
ControllerSegmentTable: RWLock() threw: Function not implemented
terminate called after throwing an instance of 'boost::interprocess::interprocess_exception'
  what():  Function not implemented
Aborted
 
About the err File in DB I got the following:
 
140414 00:07:56 mysqld_safe Starting mysqld daemon with databases from /usr/local/Calpont/mysql/db
140414  0:07:56 [Note] Event Scheduler: Loaded 0 events
140414  0:07:56 [Note] /usr/local/Calpont/mysql/libexec/mysqld: ready for connections.
Version: '5.1.73'  socket: '/usr/local/Calpont/mysql/lib/mysql/mysql.sock'  port: 3309  InfiniDB 4.5.0-1
140414  0:08:09 [Note] /usr/local/Calpont/mysql/libexec/mysqld: Normal shutdown
 
140414  0:08:09 [Note] Event Scheduler: Purging the queue. 0 events
140414  0:08:09 [Note] /usr/local/Calpont/mysql/libexec/mysqld: Shutdown complete
 
140414 00:08:09 mysqld_safe mysqld from pid file /usr/local/Calpont/mysql/db/inform-decisions.com.pid ended
140414 00:08:10 mysqld_safe Starting mysqld daemon with databases from /usr/local/Calpont/mysql/db
140414  0:08:10 [Note] Event Scheduler: Loaded 0 events
140414  0:08:10 [Note] /usr/local/Calpont/mysql/libexec/mysqld: ready for connections.
Version: '5.1.73'  socket: '/usr/local/Calpont/mysql/lib/mysql/mysql.sock'  port: 3309  InfiniDB 4.5.0-1
140414  0:08:13 InfiniDB: Started; Version: 4.5.0-1
140414  0:08:13 [Note] /usr/local/Calpont/mysql/libexec/mysqld: Normal shutdown
 
140414  0:08:13 [Note] Event Scheduler: Purging the queue. 0 events
140414  0:08:13 [Note] /usr/local/Calpont/mysql/libexec/mysqld: Shutdown complete
 
04:08:13 UTC - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.
 
key_buffer_size=50586496
read_buffer_size=4194304
max_used_connections=1
max_threads=151
thread_count=0
connection_count=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 1288010 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.
 
Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
140414 00:08:13 mysqld_safe mysqld from pid file /usr/local/Calpont/mysql/db/inform-decisions.com.pid ended
 
I have 6GbRAM in the machine.
 
Greetings,
 
 
 
davidhill
davidhill's picture
Offline
Last seen: 1 month 5 days ago
Joined: Oct 27 2009
Administrator

Posts: 595

david hill
You stated you had InfiniDB

You stated you had InfiniDB working on another VM, can you post what version of the boost library you have on both the working and non working VMs.

 

Just run the following and post please.

 

# dpkg -l | grep boost
 
Thanks, David
collazosc
collazosc's picture
Offline
Last seen: 1 month 3 weeks ago
Joined: Mar 16 2014
Junior Boarder

Posts: 4

carl colz
Hi, about your question:

Hi, about your question:

 

Working machine:

 

ii  libboost-iostreams1.46.1            1.46.1-7ubuntu3                         Boost.Iostreams Library

 

uname -ar (just in case)

 

Linux xxxxxxxxxx 3.2.0-41-virtual #66-Ubuntu SMP Thu Apr 25 03:47:17 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
 

 

Non working machine:

 

ummmm, it gives blank (strange)

 

uname -ar

Linux xxxxxxxxxxxx 2.6.18-028stab107.2 #1 SMP Mon Jul 1 21:48:35 MSD 2013 x86_64 GNU/Linux

 

 

This machine is rented as a dedicated virtual server in www.server4you.com (vserver). 

 

Regards,