"Invalid Parameter passed in addModule API" when running addModule command

11 posts / 0 new
Last post
thrieu
thrieu's picture
Offline
Last seen: 2 months 1 day ago
Joined: Nov 21 2013
Junior Boarder

Posts: 15

Chiubing Ding
"Invalid Parameter passed in addModule API" when running addModule command

Hi, I encountered "Invalid Parameter passed in addModule API" error when running addModule command,

I entered a command according to DBAdminGuide,

 

InfiniDB> addModule pm 1 SERVER_IP ROOT_PASSWORD
addmodule   Fri Apr 18 15:17:06 2014

Adding Modules pm2, please wait...

**** addModule Failed: Invalid Parameter passed in addModule API
InfiniDB>

 

What is the possible reason?

radams
radams's picture
Offline
Last seen: 2 hours 55 min ago
Joined: Jan 3 2011
Administrator

Posts: 487

Robert Adams
"Invalid Parameter passed in addModule API" when running addModu

 

 

Hi,

 

Please review the error logs and to see the cause of the issue. It is likely that the

SERVER_IP (IP_address_or_host_name) or the root_password is not working.

 

 

Thanks,

 

Robert

 

 

thrieu
thrieu's picture
Offline
Last seen: 2 months 1 day ago
Joined: Nov 21 2013
Junior Boarder

Posts: 15

Chiubing Ding
Thank you for replying!

Thank you for replying!

I am a newbie, and I am still not so clear with performance module after reading the doc.

I am sure the root password is correct. I enter an IP of the local host machine, and the machine already exists one default performance module.

Can I have multiple performace modules in the same host?

Appreciate if you can explain more about that.

Sorry for my poor English.

 

Thanks

thrieu
thrieu's picture
Offline
Last seen: 2 months 1 day ago
Joined: Nov 21 2013
Junior Boarder

Posts: 15

Chiubing Ding
PS: I bound port 13306 for

PS: I bound port 13306 for InifiniDB MySQL

 

I don't know what is the IP_address_or_host_name exactly, I just input an IP of the local machine.

 

Thanks

radams
radams's picture
Offline
Last seen: 2 hours 55 min ago
Joined: Jan 3 2011
Administrator

Posts: 487

Robert Adams
 addModule is used to add a

 

addModule is used to add a new module to an InfiniDB System. When adding a new module, the correct IP or Host name for the new server being added to the system is required. Please review the Admin Guide.

 

Thanks,

 

Robert

 

 

 

thrieu
thrieu's picture
Offline
Last seen: 2 months 1 day ago
Joined: Nov 21 2013
Junior Boarder

Posts: 15

Chiubing Ding
Thank you for your reply!

Thank you for your reply!

I entered a remote server's IP and its root password, and got an error "File Open error from addModule API".

Still don't know the condition to add a new module.

radams
radams's picture
Offline
Last seen: 2 hours 55 min ago
Joined: Jan 3 2011
Administrator

Posts: 487

Robert Adams
To add a module to InfiniDB System through the CalpontConsole

 

To add a module to InfiniDB System through the CalpontConsole:
 
1. Log on to the InfiniDB Console.
 
2. Do one of the following:
 
 To accept default module IDs and add multiple modules, type addModule module_type number_of_modules IP_address_or_host_name (separated by commas) root_password
 
For example, to add two Performance Modules with host names SRVCPT1 and SRVCPT2, type the following:
addModule pm 2 SRVCPT1,SRVCPT2 mypwd
 
 To create IDs manually one at a time, type
addModule module_ID IP_address_or_host_name root_password
 
For example to add one User Module number 1285 with host name SRVCPT1, type the following:
addModule UM1285 SRVCPT1 mypwd
 
The Calpont.xml is updated to add new modules and the appropriate files are installed to the new modules.
If the module addition fails, the InfiniDB Console displays an error message. Additional details are located in the InfiniDB Log Files on the Performance Module #1.
 
Please use the procedure above and check the error logs if a problem is encountered.
thrieu
thrieu's picture
Offline
Last seen: 2 months 1 day ago
Joined: Nov 21 2013
Junior Boarder

Posts: 15

Chiubing Ding
Appreciate for your impatient

Thank you for the time you spent.

 

It made some progress.

 

1. There was NO /root/infinidb-platform-*****.rpm, so I copied a file to there.

2. After checking, 8800 port was blocked on another machine.

 

Now in the log:

 

May 15 18:08:03 cy-server ProcessManager[30624]: 03.598917 |0|0|0| E 17 CAL0000: line: 4874 addModule - ERROR: user_installer.sh failed

 

And in getSystemStatus, is shows that pm2 is disabled.

 

When I ran the shell script manually, it throwed an error "Invalid Package Type of".

I am using CentOS. I installed InfiniDB via rpm.

 

Any possible reason? Thank you again!

thrieu
thrieu's picture
Offline
Last seen: 2 months 1 day ago
Joined: Nov 21 2013
Junior Boarder

Posts: 15

Chiubing Ding
I copied all InfiniDB rpms to

I copied all InfiniDB rpms to /root, and then tried to enable the module, it was success.

But in getSystemStatus, it displays the module is offline.

radams
radams's picture
Offline
Last seen: 2 hours 55 min ago
Joined: Jan 3 2011
Administrator

Posts: 487

Robert Adams
addModule

 

Try "removeModule pm2" and then run addModule so it runs cleanly this time.

 

 

 

Thanks,

 

Robert

 

thrieu
thrieu's picture
Offline
Last seen: 2 months 1 day ago
Joined: Nov 21 2013
Junior Boarder

Posts: 15

Chiubing Ding
It works!   Thank you!

It works!

 

Thank you!